Liron Aravot has posted comments on this change.

Change subject: core: VdcActionParametersBase - choose if command is ended by 
parent
......................................................................


Patch Set 1:

(2 comments)

https://gerrit.ovirt.org/#/c/41689/1/backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/VdcActionParametersBase.java
File 
backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/VdcActionParametersBase.java:

Line 298:         builder.append(getCommandType());
Line 299:         return builder.toString();
Line 300:     }
Line 301: 
Line 302:     public boolean isShouldBeEndedByParent() {
> please rename to shouldBeEndedByParent()
i prefer to keep it as it's the convention used for the other boolean members 
here.
Line 303:         return shouldBeEndedByParent;
Line 304:     }
Line 305: 
Line 306:     public void setShouldBeEndedByParent(boolean 
shouldBeEndedByParent) {


Line 301: 
Line 302:     public boolean isShouldBeEndedByParent() {
Line 303:         return shouldBeEndedByParent;
Line 304:     }
Line 305: 
> that would allow the clients to determine how the command should be execute
I'll separate between two different terms we currently have on our flows - 
internal commands and child commands, child command isn't always an internal 
command on the current code.
When command is executing a command it should decide how it should be ended 
(who should call the endAction() method - the executed command or the parent 
command).

for example, usually when command creates tasks it waits for all of them to 
finish and on it's endAction() method executes the endAction() for each one of 
the childs.
Line 306:     public void setShouldBeEndedByParent(boolean 
shouldBeEndedByParent) {
Line 307:         this.shouldBeEndedByParent = shouldBeEndedByParent;
Line 308:     }


-- 
To view, visit https://gerrit.ovirt.org/41689
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Id5342bee4989b44a878205c2d6094454b6ef5b2e
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liron Aravot <lara...@redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <lara...@redhat.com>
Gerrit-Reviewer: Moti Asayag <masa...@redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourf...@redhat.com>
Gerrit-Reviewer: Ravi Nori <rn...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to