Liran Zelkha has posted comments on this change.

Change subject: core: Move Job, Step to JPA
......................................................................


Patch Set 50:

(2 comments)

https://gerrit.ovirt.org/#/c/34553/50/backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/job/Job.java
File 
backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/job/Job.java:

Line 44:         @NamedQuery(name = "Job.getJobsByCorrelationId",
Line 45:                 query = "select j from Job j where j.correlationId = 
:correlationId"),
Line 46:         @NamedQuery(name = "Job.getJobsByOffsetAndPageSize",
Line 47:                 query = "select j from Job j where j.status in 
(:status) order by lastUpdateTime DESC"),
Line 48:         @NamedQuery(name = "Job.GetJobsNotInStatus",
> Please rename to Job.getJobsNotInStatus
Done
Line 49:                 query = "select j from Job j where j.status not in 
(:status) order by lastUpdateTime DESC"),
Line 50:         @NamedQuery(
Line 51:                 name = "Job.deleteCompletedJobs",
Line 52:                 query = "delete from Job j where j.autoCleared = true "


Line 361: 
Line 362:     @Override
Line 363:     public int hashCode() {
Line 364:         int result = Objects.hashCode(id);
Line 365:         return result;
> There's no need for result attribute:
Done
Line 366:     }
Line 367: 
Line 368:     @Override
Line 369:     public boolean equals(Object obj) {


-- 
To view, visit https://gerrit.ovirt.org/34553
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ifcfda7b055d37c92c1346b100101c27d594d21fb
Gerrit-PatchSet: 50
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liran Zelkha <lzel...@redhat.com>
Gerrit-Reviewer: Eli Mesika <emes...@redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liran Zelkha <lzel...@redhat.com>
Gerrit-Reviewer: Martin Mucha <mmu...@redhat.com>
Gerrit-Reviewer: Martin Peřina <mper...@redhat.com>
Gerrit-Reviewer: Moti Asayag <masa...@redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourf...@redhat.com>
Gerrit-Reviewer: Roy Golan <rgo...@redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzasp...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to