Shireesh Anjal has posted comments on this change.

Change subject: engine: Start Gluster Volume Profile command
......................................................................


Patch Set 5: (4 inline comments)

Few minor comments in-line.

....................................................
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/StartGlusterVolumeProfileCommand.java
Line 21:     }
Line 22: 
Line 23:     @Override
Line 24:     protected void setActionMessageParameters() {
Line 25:         
addCanDoActionMessage(VdcBllMessages.VAR__ACTION__START_VOLUME_PROFILE);
Since the "TYPE" describes the target of the action, the "ACTION" should just 
describe the action being performed i.e. I think a better name for this enum is 
VAR__ACTION__START_PROFILE (excluding _VOLUME_)
Line 26:         
addCanDoActionMessage(VdcBllMessages.VAR__TYPE__GLUSTER_VOLUME);
Line 27:     }
Line 28: 
Line 29:     @Override


....................................................
File 
backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/VdcBllMessages.java
Line 60:     VAR__ACTION__LOGON,
Line 61:     VAR__ACTION__LOGOFF,
Line 62:     VAR__ACTION__REBALANCE_START,
Line 63:     VAR__ACTION__ASSIGN,
Line 64:     VAR__ACTION__START_VOLUME_PROFILE,
As mentioned in a previous comment, I think this can be called just 
VAR__ACTION__START_PROFILE
Line 65: 
Line 66:     // Host statuses replacements
Line 67:     VAR__HOST_STATUS__UP,
Line 68:     VAR__HOST_STATUS__UP_MAINTENANCE_OR_NON_OPERATIONAL,


....................................................
File 
backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties
Line 554: GLUSTER_SERVERS_LIST_FAILED=Failed to fetch gluster peer list from 
server ${VdsName} on Cluster ${VdsGroupName}.
Line 555: HA_VM_FAILED=Highly Available VM ${VmName} failed. It will be 
restarted automatically.
Line 556: HA_VM_RESTART_FAILED=Restart of the Highly Available VM ${VmName} 
failed.
Line 557: GLUSTER_VOLUME_PROFILE_START=Gluster Volume ${glusterVolumeName} 
Profile started.
Line 558: GLUSTER_VOLUME_PROFILE_START_FAILED=Could not start Gluster Volume 
Profile on ${glusterVolumeName}.
A better message would be "Could not start Profiling on gluster volume 
${glusterVolumeName}"


....................................................
File 
frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
Line 694:     @DefaultStringValue("$action rebalance")
Line 695:     String VAR__ACTION__REBALANCE_START();
Line 696: 
Line 697:     @DefaultStringValue("$action volume profile")
Line 698:     String VAR__ACTION__START_VOLUME_PROFILE();
I think the action should be just called VAR__ACTION__START_PROFILE with 
defaultStringValue "$action start profiling"
Line 699: 
Line 700:     @DefaultStringValue("$action assign")
Line 701:     String VAR__ACTION__ASSIGN();
Line 702: 


--
To view, visit http://gerrit.ovirt.org/8261
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ia47f7033f080f75a6ebf8481ea4199ee32bbf4ab
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Dhandapani Gopal <dgo...@redhat.com>
Gerrit-Reviewer: Dhandapani Gopal <dgo...@redhat.com>
Gerrit-Reviewer: Moti Asayag <masa...@redhat.com>
Gerrit-Reviewer: Selvasundaram <sesub...@redhat.com>
Gerrit-Reviewer: Shireesh Anjal <san...@redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com>
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to