Ramesh N has posted comments on this change. Change subject: webadmin : GeoRep Config popup view ......................................................................
Patch Set 11: (7 comments) https://gerrit.ovirt.org/#/c/34217/11/frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/table/cell/GlusterConfigAwareCell.java File frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/table/cell/GlusterConfigAwareCell.java: Line 35: { this can be simply "return BrowserEvents.CLICK.equals( event.getNativeEvent().getType())" Line 75: = Here the conditions looks exactly opposite to what is in onBrowserEvent(). https://gerrit.ovirt.org/#/c/34217/11/frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/gluster/GlusterVolumeGeoReplicationSessionConfigModel.java File frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/gluster/GlusterVolumeGeoReplicationSessionConfigModel.java: Line 71: public void addCancelCommand(UICommand cancelCommand) { Line 72: this.cancelCommand = cancelCommand; Line 73: this.getCommands().add(cancelCommand); Line 74: } Line 75: This logic can go inside the setConfigsModel method. Line 76: public void copyConfigsToMap(List<GlusterGeoRepSessionConfiguration> configsTocopy) { Line 77: for (GlusterGeoRepSessionConfiguration currentConfig : configsTocopy) { Line 78: configsMap.put(currentConfig.getKey(), currentConfig.getValue()); Line 79: } Line 102: queryExecutionStatus Its better to rename the variable queryExecutionStatus to isExecutionAllowed https://gerrit.ovirt.org/#/c/34217/11/frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/gluster/VolumeGeoRepListModel.java File frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/gluster/VolumeGeoRepListModel.java: Line 278: selectedItem May be a better name for the variable? selectedItem https://gerrit.ovirt.org/#/c/34217/11/frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/UIMessages.java File frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/UIMessages.java: Line 419: Move this file from the patch set. https://gerrit.ovirt.org/#/c/34217/11/frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/gin/uicommon/VolumeModule.java File frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/gin/uicommon/VolumeModule.java: Line 234: Singleton Can we format this line so that it becomes easy to read? -- To view, visit https://gerrit.ovirt.org/34217 To unsubscribe, visit https://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I150946fe016d85cb378ed3d548eab5581321fbfe Gerrit-PatchSet: 11 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: anmolbabu <anb...@redhat.com> Gerrit-Reviewer: Kanagaraj M <kmayi...@redhat.com> Gerrit-Reviewer: Ramesh N <rnach...@redhat.com> Gerrit-Reviewer: Shubhendu Tripathi <shtri...@redhat.com> Gerrit-Reviewer: anmolbabu <anb...@redhat.com> Gerrit-Reviewer: automat...@ovirt.org Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches