Ramesh N has posted comments on this change.

Change subject: engine : Entity and DAO changes for Disk provisioning
......................................................................


Patch Set 4:

(4 comments)

Added DAO Test cases.

Patch set to follow.

http://gerrit.ovirt.org/#/c/36428/4/backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/gluster/StorageDevice.java
File 
backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/gluster/StorageDevice.java:

Line 18:     private String devPath;
Line 19:     private String fsType;
Line 20:     private String mountPoint;
Line 21:     private Long size;
Line 22:     private Boolean canCreateBrick;
> Is it better to have a status on StorageDevice instead? There could be a st
I know this is not a nice name. But we discussed this with VDSM also. We could 
not find any other better name without ambiguity. Any suggestion?
Line 23: 
Line 24:     public StorageDevice() {
Line 25:         super();
Line 26:     }


Line 159:             return false;
Line 160:         if (getClass() != obj.getClass())
Line 161:             return false;
Line 162:         StorageDevice other = (StorageDevice) obj;
Line 163:         if (canCreateBrick == null) {
> Use ObjectUtils helper for this
Done
Line 164:             if (other.canCreateBrick != null)
Line 165:                 return false;
Line 166:         } else if (!canCreateBrick.equals(other.canCreateBrick))
Line 167:             return false;


http://gerrit.ovirt.org/#/c/36428/4/packaging/dbscripts/storage_device_sp.sql
File packaging/dbscripts/storage_device_sp.sql:

Line 83:     WHERE id = v_id;
Line 84: END; $procedure$
Line 85: LANGUAGE plpgsql;
Line 86: 
Line 87: Create or replace FUNCTION DeleteStorageDeviceByIds(v_ids 
VARCHAR(5000))
> This is not he right way to do batch delete 
Currently I don't require batch delete. So let me delete it and add when we 
require this.
Line 88:     RETURNS VOID
Line 89:     AS $procedure$
Line 90: BEGIN
Line 91:     DELETE FROM storage_device


http://gerrit.ovirt.org/#/c/36428/4/packaging/dbscripts/upgrade/03_06_750_storage_device_tables.sql
File packaging/dbscripts/upgrade/03_06_750_storage_device_tables.sql:

Line 1: -- Add storage_device table
> script seq number is wrong. it should be 03_06_0750
Done
Line 2: CREATE TABLE storage_device
Line 3: (
Line 4:     id UUID NOT NULL,
Line 5:     name VARCHAR(1000) NOT NULL,


-- 
To view, visit http://gerrit.ovirt.org/36428
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ie95a12239429dd0c7f3282161221e8b8f639cee9
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ramesh N <rnach...@redhat.com>
Gerrit-Reviewer: Eli Mesika <emes...@redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayi...@redhat.com>
Gerrit-Reviewer: Ramesh N <rnach...@redhat.com>
Gerrit-Reviewer: Sahina Bose <sab...@redhat.com>
Gerrit-Reviewer: Shubhendu Tripathi <shtri...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to