Shubhendu Tripathi has posted comments on this change.

Change subject: webadmin: show storage devices in host
......................................................................


Patch Set 12:

(4 comments)

http://gerrit.ovirt.org/#/c/35315/12//COMMIT_MSG
Commit Message:

Line 5: CommitDate: 2015-01-11 23:12:53 +0530
Line 6: 
Line 7: webadmin: show storage devices in host
Line 8: 
Line 9:   Show all available storage devices in 'Storage Devies' sub tab
%s/Devies/Devices/g
Line 10: under Hosts .
Line 11: 
Line 12: Change-Id: I10da2f35012795de32367f295260ce9151c44909


http://gerrit.ovirt.org/#/c/35315/12/frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/gluster/HostStorageDevicesListModel.java
File 
frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/gluster/HostStorageDevicesListModel.java:

Line 46:     public HostStorageDevicesListModel() {
Line 47:         
setTitle(ConstantsManager.getInstance().getConstants().storageDevices());
Line 48:         setHelpTag(HelpTag.storage_device_list);
Line 49:         setHashName("storage_device_list"); //$NON-NLS-1$
Line 50:         setSyncStorageDevicesCommand(new UICommand("Sync Storage 
Devices", this)); //$NON-NLS-1$
Command names better set with underscores and not with spaces.
Not an issue though :)
Line 51:         setAvailableInModes(ApplicationMode.GlusterOnly);
Line 52:     }
Line 53: 
Line 54:     @Override


Line 93:     }
Line 94: 
Line 95:     @Override
Line 96:     protected String getListName() {
Line 97:         return "HostDeviceListListModel"; //$NON-NLS-1$
%s/HostDeviceListListModel/HostDeviceListModel/g
Line 98:     }
Line 99: 
Line 100:     private void syncStorageDevices() {
Line 101:         
Frontend.getInstance().runAction(VdcActionType.SyncStorageDevices, new 
VdsActionParameters(getEntity().getId()));


http://gerrit.ovirt.org/#/c/35315/12/frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/place/WebAdminApplicationPlaces.java
File 
frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/place/WebAdminApplicationPlaces.java:

Line 214:     public static final String hostBricksSubTabPlace = 
hostMainTabPlace + SUB_TAB_PREFIX
Line 215:             + "gluster_bricks"; //$NON-NLS-1$
Line 216: 
Line 217:     public static final String hostStorageDevicesSubTabPlace = 
hostMainTabPlace + SUB_TAB_PREFIX
Line 218:             + "storage_device_list"; //$NON-NLS-1$
%s/storage_device_list/storage_devices/g
Line 219: 
Line 220:     public static final String hostPermissionSubTabPlace = 
hostMainTabPlace + SUB_TAB_PREFIX
Line 221:             + "permissions"; //$NON-NLS-1$
Line 222: 


-- 
To view, visit http://gerrit.ovirt.org/35315
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I10da2f35012795de32367f295260ce9151c44909
Gerrit-PatchSet: 12
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ramesh N <rnach...@redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayi...@redhat.com>
Gerrit-Reviewer: Sahina Bose <sab...@redhat.com>
Gerrit-Reviewer: Shubhendu Tripathi <shtri...@redhat.com>
Gerrit-Reviewer: anmolbabu <anb...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to