Lior Vernia has posted comments on this change.

Change subject: core: Remove code duplication in VdsNetworkInterface.toString()
......................................................................


Patch Set 3:

(2 comments)

http://gerrit.ovirt.org/#/c/36215/3/backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/network/VdsNetworkInterface.java
File 
backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/network/VdsNetworkInterface.java:

Line 428:         setQosOverridden(sourceNic.isQosOverridden());
Line 429:         setCustomProperties(sourceNic.getCustomProperties());
Line 430:     }
Line 431: 
Line 432:     protected Map<String, Object> constructSerializationAttributes() {
> Please change the method name- maybe constructToStringAttributes()
Done
Line 433:         Map<String, Object> attributes = new LinkedHashMap<>();
Line 434:         attributes.put("id", getId());
Line 435:         attributes.put("vdsId", getVdsId());
Line 436:         attributes.put("networkName", getNetworkName());


Line 455: 
Line 456:         Map<String, Object> attributes = 
constructSerializationAttributes();
Line 457:         if (attributes != null && !attributes.isEmpty()) {
Line 458:             Iterator<Entry<String, Object>> i = 
attributes.entrySet().iterator();
Line 459:             builder.append(i.next());
> You are relying on the format of Entry.toString().
Done
Line 460:             while (i.hasNext()) {
Line 461:                 builder.append(", ").append(i.next());
Line 462:             }
Line 463:         }


-- 
To view, visit http://gerrit.ovirt.org/36215
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I94bbf7113e848f6ca8ae4a38e46303050d653135
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Lior Vernia <lver...@redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkap...@redhat.com>
Gerrit-Reviewer: Lior Vernia <lver...@redhat.com>
Gerrit-Reviewer: Martin Mucha <mmu...@redhat.com>
Gerrit-Reviewer: Moti Asayag <masa...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to