Kanagaraj M has posted comments on this change. Change subject: gluster: Sync job for gluster volume snapshots ......................................................................
Patch Set 5: (3 comments) http://gerrit.ovirt.org/#/c/35904/5/backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/gluster/GlusterVolumeSnapshotInfo.java File backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/gluster/GlusterVolumeSnapshotInfo.java: Line 5: Line 6: import org.ovirt.engine.core.common.utils.ObjectUtils; Line 7: import org.ovirt.engine.core.compat.Guid; Line 8: Line 9: public class GlusterVolumeSnapshotInfo implements Serializable { You could rename this to GlusterVolumeSnapshotListInfo, since this contains all snapshots of a volume Line 10: private static final long serialVersionUID = -768822766895441199L; Line 11: Line 12: private Guid volumeId; Line 13: private List<GlusterVolumeSnapshotEntity> snapshots; http://gerrit.ovirt.org/#/c/35904/5/backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java File backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java: Line 1420: @DefaultValueAttribute("3600") Line 1421: GlusterRefreshRateGeoRepDiscovery, Line 1422: Line 1423: @TypeConverterAttribute(Integer.class) Line 1424: @DefaultValueAttribute("5") I feel 5 seconds would be too aggressive. You could change this to 30 seconds. Line 1425: GlusterRefreshRateSnapshotDiscovery, Line 1426: Line 1427: @TypeConverterAttribute(String.class) Line 1428: @DefaultValueAttribute("AttestationService/resources/PollHosts") http://gerrit.ovirt.org/#/c/35904/5/backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/vdscommands/gluster/GlusterVolumeSnapshotInfoVDSParameters.java File backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/vdscommands/gluster/GlusterVolumeSnapshotInfoVDSParameters.java: Line 8: public GlusterVolumeSnapshotInfoVDSParameters() { Line 9: } Line 10: Line 11: public GlusterVolumeSnapshotInfoVDSParameters(Guid clusterId, Guid serverId, String volumeName, String snapshotName) { Line 12: super(serverId, volumeName, snapshotName); do we need snapshot name here? Line 13: this.clusterId = clusterId; Line 14: } Line 15: Line 16: public Guid getClusterId() { -- To view, visit http://gerrit.ovirt.org/35904 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I7b7bf79b72fc5680dab301b290e7aa860d5c714d Gerrit-PatchSet: 5 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Shubhendu Tripathi <shtri...@redhat.com> Gerrit-Reviewer: Kanagaraj M <kmayi...@redhat.com> Gerrit-Reviewer: Ramesh N <rnach...@redhat.com> Gerrit-Reviewer: Sahina Bose <sab...@redhat.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> Gerrit-Reviewer: automat...@ovirt.org Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches