Alon Bar-Lev has posted comments on this change.

Change subject: utils: ssh public key entry should contain new line
......................................................................


Patch Set 2: (1 inline comment)

....................................................
File 
backend/manager/modules/engineencryptutils/src/main/java/org/ovirt/engine/core/engineencryptutils/OpenSSHUtils.java
Line 116:         final StringBuilder buffer = new 
StringBuilder(SSH_RSA.length() + 1 + encoding.length() + (alias != null? 1 + 
alias.length(): 0));
OK, I will do that.

Although I can argue with the about above statement...

 """
 This idea that "little things don't matter because Java is already so slow" is 
what makes Java programs so slow, not Java itself.
 """

For none performance critical code paths I would vote for code simplicity than 
performance or tiny memory usage overhead.

Code should be complex (eg. dependency between allocation and usage in optional 
mode) when there is a good reason to do so.

For this reason I prefer using String.format() whenever I can, as it makes the 
code easier to read and maintain. It has nothing to do with internationalize. 
It was a missing bit in Java, that was added waaaaaaaaay too late.

Had I written this in C, no way I would not have been used sprintf().

--
To view, visit http://gerrit.ovirt.org/7027
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ifd202048b8efb8f081b10651c302b9da0718035c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alo...@redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alo...@redhat.com>
Gerrit-Reviewer: Doron Fediuck <dfedi...@redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernan...@redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to