Tomas Jelinek has posted comments on this change. Change subject: userportal\webadmin: cluster parameters override ......................................................................
Patch Set 7: (3 comments) http://gerrit.ovirt.org/#/c/31582/7/frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/editor/ListModelTypeAheadChangeableListBox.java File frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/editor/ListModelTypeAheadChangeableListBox.java: Line 39: asSuggestBox().getElement().getStyle().setColor(empty ? "gray" : "black"); //$NON-NLS-1$ $NON-NLS-2$ Line 40: } Line 41: Line 42: @Override Line 43: protected void switchSuggestions() { this method is a copy-paste of the parent with only very small modification. I would extract the else part in the parent to a standalone method called: showAllSuggestions() and in this class I'd override it to look like this: @Override protected void showAllSuggestions() { String lastText = suggestBox.getText(); super.showAllSuggestions(); suggestBox.setText(lastText); } Line 44: if (!isEnabled()) { Line 45: return; Line 46: } Line 47: http://gerrit.ovirt.org/#/c/31582/7/frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/editor/ListModelTypeAheadChangeableListBoxEditor.java File frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/editor/ListModelTypeAheadChangeableListBoxEditor.java: Line 9: Line 10: /** Line 11: * Composite Editor that uses {@link ListModelTypeAheadChangeableListBox}. Line 12: */ Line 13: public class ListModelTypeAheadChangeableListBoxEditor extends AbstractValidatedWidgetWithLabel<java.lang.String, ListModelTypeAheadChangeableListBox> s/java.lang.String/String Line 14: implements IsEditor<WidgetWithLabelEditor<String, ListModelTypeAheadChangeableListBoxEditor>> { Line 15: Line 16: private final WidgetWithLabelEditor<String, ListModelTypeAheadChangeableListBoxEditor> editor; Line 17: Line 43: public ListModelTypeAheadChangeableListBox asWidget() { Line 44: return getContentWidget(); Line 45: } Line 46: Line 47: public static abstract class NullSafeSuggestBoxRenderer implements ListModelTypeAheadListBoxEditor.SuggestBoxRenderer<String> { This is also copy pasted with one small modification. Please make this class extend ListModelTypeAheadListBoxEditor.NullSafeSuggestBoxRenderer<String> I believe the only thing you need to implement here is the public String getReplacementStringNullSafe(String data) { return data; } Line 48: Line 49: private static final CommonApplicationTemplates templates = GWT.create(CommonApplicationTemplates.class); Line 50: Line 51: @Override -- To view, visit http://gerrit.ovirt.org/31582 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ia288e46f38c03935ec9b0817833b1921f15ec9f8 Gerrit-PatchSet: 7 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Eldan Shachar <eshac...@redhat.com> Gerrit-Reviewer: Eldan Shachar <eshac...@redhat.com> Gerrit-Reviewer: Tomas Jelinek <tjeli...@redhat.com> Gerrit-Reviewer: automat...@ovirt.org Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches