Livnat Peer has posted comments on this change.

Change subject: engine: Change query to iterate using foreach
......................................................................


Patch Set 1: Looks good to me, approved

(1 inline comment)

Although hating this patch because it takes one form of unreadable code and 
change it to another form of unreadable code I agree that doing re factoring 
and fixing code should not be on a single patch.

Looking forward for a following patch to fix this method readability.

....................................................
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetVdsInterfacesByVdsIdQuery.java
Line 41:         for (final VdsNetworkInterface i : list) {
I find the following line more readable -
if (i.getBonded() == null || ( (i.getBonded) & (bondIsAttahedToValidInterface)){
interfaces.add(i);
}

and add a method for bondIsAttahedToValidInterface(List<VdsNetworkInterface>, 
bond)

--
To view, visit http://gerrit.ovirt.org/6696
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I79ec5babb9cb0a2166cc18b5617f1ce944fdd722
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Mike Kolesnik <mkole...@redhat.com>
Gerrit-Reviewer: Livnat Peer <lp...@redhat.com>
Gerrit-Reviewer: Moti Asayag <masa...@redhat.com>
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to