Arik Hadas has posted comments on this change. Change subject: core: ExportVMCommand storage allocation checks ......................................................................
Patch Set 1: (2 comments) http://gerrit.ovirt.org/#/c/32897/1/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ExportVmCommand.java File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ExportVmCommand.java: Line 161: // get the snapshots that are going to be exported and have memory Line 162: snapshotsWithMemory = getSnapshotsToBeExportedWithMemory(); Line 163: Line 164: // check destination storage have free space Line 165: handleDestStorageDomain(disksForExport); missing 'return false'? Line 166: Line 167: SnapshotsValidator snapshotValidator = new SnapshotsValidator(); Line 168: if (!(checkVmInStorageDomain() Line 169: && validate(new StoragePoolValidator(getStoragePool()).isUp()) Line 188: getMemoryDisks we can argue whether the memory files are disks or volumes, but let's keep it aside and be consistent with the rest of the places in the code - how about rename it to getMemoryVolumes? -- To view, visit http://gerrit.ovirt.org/32897 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ic65fdc7324babacda2d1d49dc7157f6799b922f2 Gerrit-PatchSet: 1 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Vered Volansky <vvola...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Arik Hadas <aha...@redhat.com> Gerrit-Reviewer: Vered Volansky <vvola...@redhat.com> Gerrit-Reviewer: automat...@ovirt.org Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches