Liron Aravot has posted comments on this change.

Change subject: core, db: add getQosByDiskProfile
......................................................................


Patch Set 4:

(2 comments)

http://gerrit.ovirt.org/#/c/29814/4/backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/qos/StorageQosDaoTest.java
File 
backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/qos/StorageQosDaoTest.java:

Line 100:     @Test
Line 101:     public void getQosByDiskProfileId() {
Line 102:         StorageQos qos = 
dao.GetQosByDiskProfileId(FixturesTool.DISK_PROFILE_1);
Line 103:         assertNotNull(qos);
Line 104:         assertEquals(FixturesTool.QOS_ID_1, qos.getId());
> didn't get you ..
getQodDao().get(qosId)

assertEquals(expectedProfileId, gos.getDiskProfileId())
Line 105:     }
Line 106: 


http://gerrit.ovirt.org/#/c/29814/4/packaging/dbscripts/qos_sp.sql
File packaging/dbscripts/qos_sp.sql:

Line 86: RETURN QUERY SELECT qos.*
Line 87:    FROM qos
Line 88:    JOIN disk_profiles ON
Line 89:       (qos.id = disk_profiles.qos_id AND
Line 90:       disk_profiles.id = v_disk_profile_id);
> * Are this incorrect?
please move it, it's zero effort and it's more readable.
Line 91: END; $procedure$
Line 92: LANGUAGE plpgsql;


-- 
To view, visit http://gerrit.ovirt.org/29814
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: If8e9b246172497412b3dc13d46af85fd155713cf
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Gilad Chaplik <gchap...@redhat.com>
Gerrit-Reviewer: Arik Hadas <aha...@redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchap...@redhat.com>
Gerrit-Reviewer: Liron Aravot <lara...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to