Yedidyah Bar David has posted comments on this change.

Change subject: packaging: setup: getting a cert for a remote wsp via support 
files
......................................................................


Patch Set 2:

(3 comments)

http://gerrit.ovirt.org/#/c/30932/2/packaging/setup/ovirt_engine_setup/websocket_proxy/constants.py
File packaging/setup/ovirt_engine_setup/websocket_proxy/constants.py:

Line 125: 
Line 126:     REMOTE_ENGINE_HOST = 'OVESETUP_CONFIG/remoteEngineHost'
Line 127: 
Line 128:     WSP_CERTIFICATE_CHAIN = 'OVESETUP_CONFIG/wspCertificateChain'
Line 129:     WSP_T_CERT_FILENAME = 'OVESETUP_CONFIG/wspTempCertFilename'
I do not think you need this. If you do, please rename - what's "T"?
Line 130:     REMOTE_ENGINE_CER = 'OVESETUP_CONFIG/remoteEngineCer'
Line 131: 
Line 132: 
Line 133: @util.export


http://gerrit.ovirt.org/#/c/30932/2/packaging/setup/plugins/ovirt-engine-setup/websocket_proxy/pki.py
File packaging/setup/plugins/ovirt-engine-setup/websocket_proxy/pki.py:

Line 251:                 else:
Line 252:                     goodfile = False
Line 253:                     while not goodfile:
Line 254:                         filename = self.dialog.queryString(
Line 255:                             
name=owspcons.ConfigEnv.WSP_T_CERT_FILENAME,
We do not generally use named constants in dialogs...

I thought this will be the filename. I do not think that's needed. IMO just 
generate a random file and tell user to copy there and "Press Enter when ready".
Line 256:                             note=_(
Line 257:                                 '\nPlease input the location of the 
file '
Line 258:                                 'where you copied\n'
Line 259:                                 'back the signed cert on this host: '


Line 263:                         try:
Line 264:                             with open(filename) as f:
Line 265:                                 self.environment[
Line 266:                                     
owspcons.ConfigEnv.WSP_CERTIFICATE_CHAIN
Line 267:                                 ] = ''.join(f.readlines())
why not just f.read()?
Line 268:                                 goodfile = True
Line 269:                         except EnvironmentError:
Line 270:                             self.logger.error(
Line 271:                                 _(


-- 
To view, visit http://gerrit.ovirt.org/30932
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I24384e213470ff521a8a3651920fef594e4d7c9d
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Simone Tiraboschi <stira...@redhat.com>
Gerrit-Reviewer: Lev Veyde <lve...@redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbona...@redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stira...@redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <d...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to