anmolbabu has posted comments on this change.

Change subject: engine : volume profile export to pdf command
......................................................................


Patch Set 19:

(3 comments)

http://gerrit.ovirt.org/#/c/28000/19/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterVolumeProfilePdfExportCommand.java
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterVolumeProfilePdfExportCommand.java:

Line 28: import com.itextpdf.text.pdf.PdfWriter;
Line 29: 
Line 30: public class GlusterVolumeProfilePdfExportCommand extends 
GlusterCommandBase<GlusterVolumeCreatePdfParameters> {
Line 31: 
Line 32:     PdfCreator createPdf;
> change the object to pdfCreator as well?
Done :)
Line 33: 
Line 34:     String[] fopColumnHeaders = { "File operation", "No. of 
Invocations", "Max-Latency", "Min-Latency", "Avg-Latency" };
Line 35:     private static final int CHAPTER_VERTICAL_SPACES = 3;
Line 36:     private static final int SUB_HEADING_VERTICAL_SPACES = 2;


Line 93:                     || 
profile.getProfileStats().get(0).getBlockStats() == null
Line 94:                     || 
profile.getProfileStats().get(1).getBlockStats() == null
Line 95:                     || profile.getProfileStats().get(0).getFopStats() 
== null
Line 96:                     || profile.getProfileStats().get(1).getFopStats() 
== null) {
Line 97:                 return;
> return or continue with next profile?
Done
Line 98:             }
Line 99:             Paragraph profileIdentityParagraph = new 
Paragraph(profile.getName(), PdfCreator.subHeadingFont);
Line 100:             createPdf.addNVerticalSpaces(profileIdentityParagraph, 
SUB_HEADING_VERTICAL_SPACES);
Line 101: 


Line 131:                                     + " have been read in the current 
profiling interval out of " + dataRead.getSecond() + 
dataRead.getFirst().toString() + " during profiling",
Line 132:                                     
dataWrittenInCurrentInterval.getSecond() + 
dataWrittenInCurrentInterval.getFirst().toString()
Line 133:                                     + " have been written in the 
current profiling interval out of "
Line 134:                                     + dataWritten.getSecond() + 
dataWritten.getFirst().toString() + " during profiling"
Line 135:                     };
> refactor and move the profileSummary to a different method?
Done
Line 136: 
Line 137:             profileDetails.add(createPdf.createList(profileSummary));
Line 138:         }
Line 139:         document.add(profileDetails);


-- 
To view, visit http://gerrit.ovirt.org/28000
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I208a77456487a5f735948d6cf9fec54f004b6e89
Gerrit-PatchSet: 19
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: anmolbabu <anb...@redhat.com>
Gerrit-Reviewer: Alexander Wels <aw...@redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayi...@redhat.com>
Gerrit-Reviewer: Sahina Bose <sab...@redhat.com>
Gerrit-Reviewer: Shubhendu Tripathi <shtri...@redhat.com>
Gerrit-Reviewer: anmolbabu <anb...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to