Moti Asayag has posted comments on this change.

Change subject: engine,webadmin: Encapsulate network properties logic in util
......................................................................


Patch Set 8: Code-Review-1

(2 comments)

http://gerrit.ovirt.org/#/c/27577/8/backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/utils/customprop/NetworkCustomPropertiesUtils.java
File 
backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/utils/customprop/NetworkCustomPropertiesUtils.java:

Line 6: import java.util.Map;
Line 7: 
Line 8: import org.ovirt.engine.core.common.businessentities.network.Network;
Line 9: 
Line 10: public abstract class NetworkCustomPropertiesUtils {
providing the arguments for UserPredefinedProperties and UserDefineProperties 
in the c'tor will reduce the need for extending this class in the 2 various 
contexts, reduce the need for this class to be a static and will allow to add 
unit tests for it.

Also, naming this class NetworkCustomPropertiesValidator will describe its 
purpose better.
Line 11: 
Line 12:     private static String BRIDGE_OPTS = "bridge_opts";
Line 13: 
Line 14:     private CustomPropertiesUtils utils;


Line 12:     private static String BRIDGE_OPTS = "bridge_opts";
Line 13: 
Line 14:     private CustomPropertiesUtils utils;
Line 15:     private Map<String, String> validProperties;
Line 16:     private Map<String, String> validPropertiesNonVm;
IMO nonVmNetworkValidProperties will describe the nature of this property better
Line 17: 
Line 18:     public NetworkCustomPropertiesUtils() {
Line 19:         utils = SimpleCustomPropertiesUtil.getInstance();
Line 20:         validProperties = new HashMap<String, String>();


-- 
To view, visit http://gerrit.ovirt.org/27577
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ib46fffc434a647cc2c603631c0af920ca41ad2f5
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Lior Vernia <lver...@redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkap...@redhat.com>
Gerrit-Reviewer: Lior Vernia <lver...@redhat.com>
Gerrit-Reviewer: Moti Asayag <masa...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to