anmolbabu has posted comments on this change. Change subject: engine : Refactored gluster volume profile query ......................................................................
Patch Set 3: (2 comments) http://gerrit.ovirt.org/#/c/27468/3/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeProfileInfoQuery.java File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeProfileInfoQuery.java: Line 28: getUpServerId(getParameters().getClusterId()), Line 29: getGlusterVolumeName(getParameters().getVolumeId()), Line 30: ((GlusterVolumeProfileParameters)getParameters()).isNfs())); Line 31: Line 32: getQueryReturnValue().setReturnValue((((GlusterVolumeProfileParameters)getParameters()).isNfs()) ? (GlusterVolumeProfileInfo) returnValue.getReturnValue() : populateBrickNames((GlusterVolumeProfileInfo) returnValue.getReturnValue())); > More readable this way? Done Line 33: } Line 34: Line 35: protected GlusterVolumeProfileInfo populateBrickNames(GlusterVolumeProfileInfo profileInfo) { Line 36: List<BrickProfileDetails> brickProfiles= profileInfo.getBrickProfileDetails(); http://gerrit.ovirt.org/#/c/27468/3/backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/utils/SizeConverter.java File backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/utils/SizeConverter.java: Line 77: * This method achieves this iteratively by, Line 78: * 1. Convert the size into highest expressable unit using the above autoConvert method Line 79: * 2. Concat to convertedSize string the converted size and its unit Line 80: * 3. Set the size to reminder Line 81: */ > Do we really want to represent size this way, rather than 1.18256 GB (in yo I thought it would be more accurate.But the complete string length might sometimes be too big.So,I'll remove this newly introduced method and use the autoconvert itself. Line 82: Line 83: public static String autoPreciseConvert(long size, SizeUnit inUnit) { Line 84: String convertedSize = ""; Line 85: while(size > 1024) { -- To view, visit http://gerrit.ovirt.org/27468 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I41d80dbb8b6865f67fcadf78baed2a813c423d03 Gerrit-PatchSet: 3 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: anmolbabu <anb...@redhat.com> Gerrit-Reviewer: Kanagaraj M <kmayi...@redhat.com> Gerrit-Reviewer: Ramesh N <rnach...@redhat.com> Gerrit-Reviewer: Sahina Bose <sab...@redhat.com> Gerrit-Reviewer: Shubhendu Tripathi <shtri...@redhat.com> Gerrit-Reviewer: anmolbabu <anb...@redhat.com> Gerrit-Reviewer: automat...@ovirt.org Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches