Tal Nisan has posted comments on this change.

Change subject: core: make clear use of filterImageDisks.
......................................................................


Patch Set 1:

Another nice approach might be to use a bit mask filter, something like:
 FILTER_SHARABLE = 1;
 FILTER_NOT_ACTIVE = 2;
 FILTER_SNAPABLE = 4;

And call the filter method with filter(FILTER_SHARABLE & FILTER_SNAPABLE)
This way it's more readable and the order is not important and the method calls 
are a bit shorter than when using a builder.
The current implementation suggested here makes no real sense to me, those are 
still boolean constants and a mistake in the parameter order is more likely to 
happen there

-- 
To view, visit http://gerrit.ovirt.org/25349
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I54a22319d7005449ec4c3ecd285d81870b1c307e
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipc...@redhat.com>
Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com>
Gerrit-Reviewer: Daniel Erez <de...@redhat.com>
Gerrit-Reviewer: Liron Ar <lara...@redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipc...@redhat.com>
Gerrit-Reviewer: Sergey Gotliv <sgot...@redhat.com>
Gerrit-Reviewer: Tal Nisan <tni...@redhat.com>
Gerrit-Reviewer: Vered Volansky <vvola...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: No
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to