Omer Frenkel has posted comments on this change. Change subject: core: introduce RunVmCommand#RunVmFlow ......................................................................
Patch Set 20: (2 comments) http://gerrit.ovirt.org/#/c/22663/20/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java: Line 680: .getVdsGroupCompatibilityVersion())); Line 681: } Line 682: Line 683: protected void fetchVmDisksFromDb() { Line 684: if (disksFetched) { maybe better to check if the list in the vm is not null and empty Line 685: return; Line 686: } Line 687: VmHandler.updateDisksFromDb(getVm()); Line 688: disksFetched = true; Line 974: Line 975: /** Line 976: * @return true if a stateless snapshot exists for the VM, false otherwise Line 977: */ Line 978: private boolean isVmRunningAsStateless() { maybe rename this to isStatelessSnapshotExists? the name of this one and the one above are too similar to understand when to use which Line 979: if (cachedVmIsRunningStateless == null) { Line 980: cachedVmIsRunningStateless = isStatelessSnapshotExistsForVm(); Line 981: } Line 982: return cachedVmIsRunningStateless; -- To view, visit http://gerrit.ovirt.org/22663 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I2a3f062323c4246b45757d3062478c0109d70708 Gerrit-PatchSet: 20 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Arik Hadas <aha...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Arik Hadas <aha...@redhat.com> Gerrit-Reviewer: Omer Frenkel <ofren...@redhat.com> Gerrit-Reviewer: Roy Golan <rgo...@redhat.com> Gerrit-Reviewer: automat...@ovirt.org Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches