Doron Fediuck has posted comments on this change. Change subject: core: Remove pubkey2ssh ......................................................................
Patch Set 7: (4 inline comments) Juan, Generally speaking it looks fine. There are some minor issues I'd like you to handle, as well as adding some debug messages, since this is really hard to decipher when such code is out in the wild. .................................................... File backend/manager/modules/engineencryptutils/src/main/java/org/ovirt/engine/core/engineencryptutils/OpenSSHUtils.java Line 140: public static final byte[] getKeyFingerprintBytes(final PublicKey key) { Can you please add some debug messages here and is the relevant methods as well? .................................................... File backend/manager/modules/engineencryptutils/src/main/java/org/ovirt/engine/core/engineencryptutils/StoreUtils.java Line 74: private static String ssh(String keystore, String password, String alias) { Please rename ssh to something more descriptive, such as getPublicSSHKey. Line 108: System.out.println("StoreUtils -[enc|dec|pvk] -store=path/to/keystore-file -pass=keystore-pass -string='string to be enc/decrypted' [-alias='cert alias']"); pvk should not be visible. Please remove it. Line 115: System.out.println("What do you wish me to do? -please specify -enc, -dec, -pvk or -pubkey2ssh"); Please remove pvk. -- To view, visit http://gerrit.ovirt.org/3138 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Iea3223e58299a84a82391fdd134e43b89750ef4b Gerrit-PatchSet: 7 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Juan Hernandez <juan.hernan...@redhat.com> Gerrit-Reviewer: Doron Fediuck <dfedi...@redhat.com> Gerrit-Reviewer: Juan Hernandez <juan.hernan...@redhat.com> Gerrit-Reviewer: Ofer Schreiber <oschr...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches