Hi,
On Mon, Jul 6, 2026 at 7:31 PM Doug Anderson <[email protected]> wrote:
>
> Hi,
>
> On Mon, Jul 6, 2026 at 3:44 PM Nicolás Antinori
> <[email protected]> wrote:
> >
> > Replace mipi_dsi_* functions with their non-deprecated mipi_dsi_*_multi
> > counterparts. This change reduces error-checking boilerplate and improves
> > readability.
> >
> > Signed-off-by: Nicolás Antinori <[email protected]>
> > ---
> > Changelog:
> > v2:
> > Implement feedback from the previous thread to simplify code in the
> > novatek_nt37801_prepare() function. This converts novatek_nt37801_on() to
> > return void and passes the mipi_dsi_multi_context struct directly as an
> > argument.
> >
> > v1:
> > https://lore.kernel.org/dri-devel/[email protected]/T/#u
> >
> > drivers/gpu/drm/panel/panel-novatek-nt37801.c | 110 ++++++++----------
> > 1 file changed, 48 insertions(+), 62 deletions(-)
>
> Yah, looks great. Thanks!
>
> Reviewed-by: Douglas Anderson <[email protected]>
>
> ...barring anything else coming up, I'll plan to apply in ~1 week.
Pushed to drm-misc-next:
[1/1] drm/panel: novatek-nt37801: Use mipi_dsi_*_multi() functions
commit: 5958ff1a715dd885210ce7208f1aa1fa930e8671