Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider: - [Medium] The commit message claims to introduce masks for RGB/YCbCr444 and YCbCr420 and add a 'version_1' suffix to MAX_DELTA_BPP, but these changes are absent from the patch diff. --
commit c43e818317532135cb07d6c396122c12f12acaca Author: Nemesa Garg <[email protected]> drm/dp: Add max bpp delta computation constants This commit defines macros used for decoding DSC max bpp delta values from the sink DPCD. It introduces definitions for delta scaling and shifts for various formats. > drm/dp: Add max bpp delta computation constants > > Define macros used for decoding DSC max bpp delta values > from the sink DPCD. This includes per-format masks for > RGB/YCbCr444 and YCbCr420, as well as definitions for delta > scaling and the YCbCr420 bit shift. Also add version_1 as > suffix to MAX_DELTA_BPP. > > v2: Move constants under 0x6E register. [Ankit] > Add mask for Native 422 also. [Ankit] > v3: Rename _DSC_NATIVE4222 to _DSC_NATIVE_YCbCr422. [Ankit] > v4: Move Version_1 edit ti patch_1. [Ankit] > Add shift mask for native also. [sashiko] [Severity: Medium] Does the commit message accurately reflect the changes in the patch? The message states it adds per-format masks for RGB/YCbCr444 and YCbCr420, as well as a version_1 suffix to MAX_DELTA_BPP. However, the version_1 suffix change was moved to another patch according to the v4 notes, and the per-format masks are already present in the baseline context of include/drm/display/drm_dp.h. Could the commit message be updated to remove the claims about the masks and the version_1 suffix so it matches the actual patch contents? -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=3
