Let's do it in this thread.
I am working on the target id registry, but was curious about people's option about one naming: "add_attr_option" vs "add_config_option". In the RFC, to configure the schema of a target id, we allow using the syntax below: ``` TVM_REGISTER_TARGET_ID("llvm") .add_attr_option<Bool>("system_lib"); .add_attr_option<String>("mtriple"); .add_attr_option<String>("mattr"); ``` This allows users to set 3 attributes of llvm: system_lib, mtriple and mattr. I was wondering if it is slightly better to use "config" instead of "attr", i.e. use "add_config_option" instead. The primary reason is that we have been using "attr" too much in the codebase, which makes its meaning vague; but config seems to be more informative in this case. Would love to hear what you guys think :-) --- [Visit Topic](https://discuss.tvm.ai/t/rfc-tvm-target-specification/6844/36) to respond. You are receiving this because you enabled mailing list mode. To unsubscribe from these emails, [click here](https://discuss.tvm.ai/email/unsubscribe/693672439c067a57193e7cd12e761a9c5c46324b379ef0f917150077d72414a9).