On 08/03/2011 17:18, rj...@apache.org wrote: <snip/> > Modified: tomcat/trunk/java/org/apache/catalina/connector/Request.java > URL: > http://svn.apache.org/viewvc/tomcat/trunk/java/org/apache/catalina/connector/Request.java?rev=1079444&r1=1079443&r2=1079444&view=diff > ============================================================================== > --- tomcat/trunk/java/org/apache/catalina/connector/Request.java (original) > +++ tomcat/trunk/java/org/apache/catalina/connector/Request.java Tue Mar 8 > 17:18:16 2011 <snip/> > @@ -2450,6 +2453,16 @@ public class Request > return (inputBuffer.available() > 0); > } > > + /** > + * Disable swallowing of remaining input if configured > + */ > + protected void disableSwallowInput() { > + Context context = getContext(); > + if (context != null && !context.getSwallowAbortedUploads()) { > + coyoteRequest.action(ActionCode.DISABLE_SWALLOW_INPUT, null); > + } > + } > + <snip/>
This method name confused me the first time I read the code. checkSwallowInput() might be a better name Mark --------------------------------------------------------------------- To unsubscribe, e-mail: dev-unsubscr...@tomcat.apache.org For additional commands, e-mail: dev-h...@tomcat.apache.org