On 14/04/2010, Mark Thomas <ma...@apache.org> wrote:
> On 13/04/2010 17:48, Filip Hanik - Dev Lists wrote:
>  > This makes zero sense and I would do a -1 on this commit and the bug in
>  > general.
>  > What effectively has happened here is that there has been a public API
>  > change without any justification.
>  >
>  > Since this is a mutable field, you've now made it non mutable. and in
>  > there lies the change.
>
>
> Fair point. I'll remove the final but make it volatile to avoid any
>  threading issues.

Sorry to go on about this, but AFAICT volatile does not really help here.
The boolean is not used for communication between threads, it is used
as a configuration option.

If two different threads want two different values then there is a
conflict. If there is never any need to change the value, then there
is no need for volatile.

Is the current API really immutable at this stage?

>  Mark
>
>
>  >
>  > Filip
>  >
>  > On 04/12/2010 12:59 PM, sebb wrote:
>  >> On 12/04/2010, Mark Thomas<ma...@apache.org>  wrote:
>  >>
>  >>> On 12/04/2010 11:53, Tim Funk wrote:
>  >>>   >  This seems like an odd thing to make a constant. (Is something else
>  >>>   >  setting this or was there an intention for this to be set?
>  >>> Especially
>  >>>   >  since it is used only once in this file)
>  >>>
>  >>>
>  >>> It isn't entirely clear. I suspect it was going to be made configurable
>  >>>   at start-up at some point. The naming convention implies constant.
>  >>> If it
>  >>>   is ever made configurable, the final can be removed if required.
>  >>>
>  >> This was done to fix:
>  >>
>  >> https://issues.apache.org/bugzilla/show_bug.cgi?id=49089
>  >>
>  >> If it is ever made mutable, please consider making it a private
>  >> instance variable instead of a thread-hostile mutable static.
>  >>
>  >>
>  >>>   Mark
>  >>>
>  >>>
>  >>>   >
>  >>>   >  -Tim
>  >>>   >
>  >>>   >  On 4/12/2010 5:35 AM, ma...@apache.org wrote:
>  >>>   >>  Author: markt
>  >>>   >>  Date: Mon Apr 12 09:35:52 2010
>  >>>   >>  New Revision: 933165
>  >>>   >>
>  >>>   >>  URL: http://svn.apache.org/viewvc?rev=933165&view=rev
>  >>>   >>  Log:
>  >>>   >>  Make public constant final
>  >>>   >>
>  >>>   >>  Modified:
>  >>>   >>
>  >>> tomcat/trunk/java/org/apache/catalina/tribes/io/ChannelData.java
>  >>>   >>
>  >>>   >>  Modified:
>  >>>   >>  tomcat/trunk/java/org/apache/catalina/tribes/io/ChannelData.java
>  >>>   >>  URL:
>  >>>   >>
>  >>> 
> http://svn.apache.org/viewvc/tomcat/trunk/java/org/apache/catalina/tribes/io/ChannelData.java?rev=933165&r1=933164&r2=933165&view=diff
>  >>>
>  >>>   >>
>  >>>   >>
>  >>> 
> ==============================================================================
>  >>>
>  >>>   >>
>  >>>   >>  ---
>  >>> tomcat/trunk/java/org/apache/catalina/tribes/io/ChannelData.java
>  >>>   >>  (original)
>  >>>   >>  +++
>  >>> tomcat/trunk/java/org/apache/catalina/tribes/io/ChannelData.java
>  >>>   >>  Mon Apr 12 09:35:52 2010
>  >>>   >>  @@ -38,7 +38,7 @@ import java.sql.Timestamp;
>  >>>   >>    public class ChannelData implements ChannelMessage {
>  >>>   >>        public static final ChannelData[] EMPTY_DATA_ARRAY = new
>  >>>   >>  ChannelData[0];
>  >>>   >>
>  >>>   >>  -    public static boolean USE_SECURE_RANDOM_FOR_UUID = false;
>  >>>   >>  +    public static final boolean USE_SECURE_RANDOM_FOR_UUID =
>  >>> false;
>  >>>   >>
>  >>>   >>        /**
>  >>>   >>         * The options this message was sent with
>  >>>   >
>  >>>   >
>  >>> ---------------------------------------------------------------------
>  >>>   >  To unsubscribe, e-mail: dev-unsubscr...@tomcat.apache.org
>  >>>   >  For additional commands, e-mail: dev-h...@tomcat.apache.org
>  >>>   >
>  >>>
>  >>>
>  >>>
>  >>>
>  >>>   ---------------------------------------------------------------------
>  >>>   To unsubscribe, e-mail: dev-unsubscr...@tomcat.apache.org
>  >>>   For additional commands, e-mail: dev-h...@tomcat.apache.org
>  >>>
>  >>>
>  >>>
>  >> ---------------------------------------------------------------------
>  >> To unsubscribe, e-mail: dev-unsubscr...@tomcat.apache.org
>  >> For additional commands, e-mail: dev-h...@tomcat.apache.org
>  >>
>  >>
>  >>
>  >
>  >
>  > ---------------------------------------------------------------------
>  > To unsubscribe, e-mail: dev-unsubscr...@tomcat.apache.org
>  > For additional commands, e-mail: dev-h...@tomcat.apache.org
>  >
>
>
>
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: dev-unsubscr...@tomcat.apache.org
>  For additional commands, e-mail: dev-h...@tomcat.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@tomcat.apache.org
For additional commands, e-mail: dev-h...@tomcat.apache.org

Reply via email to