On 06/09/2024 16:13, Felix Schumacher wrote:
Nice to see, that plantuml really works.
+1
Thanks again for your help getting it to behave the way we (OK - I) want.
We could use a few shortcuts to make the code more readable(?).
* activating an actor can be done by adding "++" to the message line, so
instead of writing
a -> b: message()
activate b
we could shorten it to
a -> b ++: message()
* deactivating an actor directly after a return message, can be
shortened using "return"
a <<-- b
deactivate b
can be replaced by
return
Those look good to me. I'll see about making those refactorings.
Another thing worth to mention might be, that the plantuml plug-in in VS
Code will look at the file ending and expect it to be one of
|*.wsd|,|*.pu|,|*.puml|,|*.plantuml|,|*.iuml|
I'll change the extension to plantuml - might as well be explicit.
Mark
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@tomcat.apache.org
For additional commands, e-mail: dev-h...@tomcat.apache.org