Filip Hanik - Dev Lists wrote:
it's more than just cool, its extremely practical.
If I only want to "unregister READ", all I have to do is
register(getRegisteredOps() & (~OP_READ))
with the enums, that are not as cool, I need a little piece of code that
singles it out.
For sure, with enums, you definitely don't look as cool since you'd be
writing unregister(OP_READ) :D
I'll leave the enum in there, but if you change your mind, I like the
"and/or" tricks, and be happy to stick them back in,
it's just not worth delaying the impl effort for
I agree and/or tricks are cool. It feels like C, and I enjoy that in
APR, but I think it's less appropriate in a Java API (where Sun
demonstrated you have to think that objects are free, and GC does not
exist :D ).
BTW, I don't understand why you like NIO, those Java APIs are not fun ;)
Rémy
---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]