Many tests file names are *JUnitTest.java[1] even though it is an integration test or distributed test. After we segregated into respective folders and removed the test category it is not visible which test it is unless we look back into the path of the source directory (integrationTest or distributedTest).
So I wanted to rename tests to reflect test category. Let me know if there is okay and if I do rename are there any downstream impacts (eg: metrics, auto diagnosis etc) Any integration test will be renamed as *IntegrationTest.java Any distributed test will be renamed as *DistributedTest.java Any unit test will be renamed as *Test.java. [1] https://github.com/apache/geode/blob/develop/geode-core/src/integrationTest/java/org/apache/geode/internal/cache/ComplexDiskRegionJUnitTest.java