On Sun, Aug 23, 2026 at 8:31 PM Morten Brørup <[email protected]> 
wrote:
>
> Added graph node profiling stats, build time configurable by enabling
> RTE_GRAPH_PROFILE in rte_config.h.
>
> Signed-off-by: Morten Brørup <[email protected]>
> ---
> v17:
> * Snapshot cycles as positive number, and subtract after processing.
>   (Robin Jarry)
> v16:
> * Refactored range bucketing for clarity and performance. (AI)
> v15:
> * Used the term "ranges" instead of "intervals". (AI)
> * Described the last range as "%u+" instead of "[%u;[".
>   Correct would be "[%u;+∞[", but prefer ASCII here.
> v14:
> * Changed some minor details suggested by AI.
> v13:
> * Fixed cache alignment; array should be aligned, not struct.
> * Changed some minor details suggested by AI.
> v12:
> * Multiply printed percent values by 100.0. (AI)
> * Added to release note that this feature is disabled by default. (AI)
> v11:
> * Fixed signedness comparison and copy-paste bug.
> v10:
> * Use intervals instead of point samples. (Robin Jarry)
> * Do not double-indent printf continuations.
>   Follows existing coding style in the file, and
>   avoids a long line warning from checkpatch.
> * Rebased.
>   Moved release note to 26.11 file.
> v9:
> * Fixed comment still mentioning 32 objects.
> * Moved sample size array outside loop. (AI)
> * Added release note. (AI)
> v8:
> * Added static const array as local variable, instead of indexing directly
>   into const array. (AI)
>   This also eliminates the space required between "} [idx];" weirdness.
> * Added build time configurable RTE_GRAPH_PROFILE_BURST_SIZE to replace
>   the hardcoded burst size of 32. (AI)
> v7:
> * Use RTE_DIM() in histogram for loop.
> * Added static_assert for histogram index values.
> * Minor details to please checkpatch.
>   Although I disagree with requiring a space when indexing into
>   a constant array "(const type []){values} [idx];",
>   I have changed the code to comply.
> v6:
> * Consolidate the four histogram entries into one array. (Saeed Bishara)
> * Sample at 32 objs instead of a half burst. (Saeed Bishara)
> * Moved stats to different location in rte_node structure. (Jerin)
> * Minor details to please checkpatch.
> v5:
> * Added stats for a half burst and a full burst.
> v4:
> * Added documentation. (AI)
> * Added more comments. (AI)
> * Improved dump. (AI)
> * Debug shows both cycles/call and cycles/obj.
> v3:
> * Debug shows cycles/obj instead of cycles/call.
> * Fixed missing --in-reply-to.
> v2:
> * Fixed indentation.
> ---
>  config/rte_config.h                    |  4 ++
>  doc/guides/prog_guide/graph_lib.rst    |  5 ++
>  doc/guides/rel_notes/release_26_11.rst |  9 ++++
>  lib/graph/graph_debug.c                | 67 ++++++++++++++++++++++++++
>  lib/graph/node.c                       |  2 +
>  lib/graph/rte_graph_worker_common.h    | 57 ++++++++++++++++++++--


Acked-by: Jerin Jacob <[email protected]>

Reply via email to