On Fri, Sep 8, 2017, at 01:16 AM, Emilio Cobos Álvarez wrote:
> This is very context dependent, I'd never omit a name in a function that
> takes (Element& aParent, Element& aChild), but it seems reasonable to
> omit it in the case where there's no better name, like (InsertionKind
> aInsertionKind) or (Element& aElement).

I don't agree with having code style more context dependent.

My concern is that, people don't familiar with the code style enough
would easily get confused by the mixed situation. Context-dependent code
style also means we would not be able to create lint for this kind of
code, and we may have more dispute during review process, which would
make things less productive.

We currently write things like "(Element& aElement)" which seems to be
redundant, but if you see lots of "(Element&)", you may start thinking
that "(Element&, Element&)" is also okay, and argue with reviewer that
you are seeing this kind of naming elsewhere.

I can see that these names aren't very helpful, and the wish to make
code more concise, but I don't think it's worth given that it may
confuse new readers and writers (in addition to confusing existing
contributors who have got used to the current style).

- Xidorn
_______________________________________________
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform

Reply via email to