So after a nearly 2 year hiatus, I'm back to editing the Selectors 4 spec...

I'm looking over the set of -moz- selectors
  
http://mxr.mozilla.org/mozilla-central/source/layout/style/nsCSSPseudoClassList.h
and wondering which ones we need to put on the standards track.

(A) So far we already have on the standards track

  :-moz-only-whitespace as :blank
    http://www.w3.org/TR/selectors4/#the-blank-pseudo
    **Please, if you all have better name suggestions, we welcome them.**
    [ :blank imho sounds like a blank form element, which we might want
      a selector for in the future. :/ ]

  :-moz-any() as :matches()
    http://www.w3.org/TR/selectors4/#matches

  :-moz-any-link as :any-link
    http://www.w3.org/TR/selectors4/#the-any-link-pseudo

  :-moz-dir() as :dir()
    http://www.w3.org/TR/selectors4/#the-dir-pseudo
    Unprefixing bug: https://bugzilla.mozilla.org/show_bug.cgi?id=859301

  :-moz-read-only as :read-only ??
  :-moz-read-write as :read-write ??
    http://www.w3.org/TR/selectors4/#rw-pseudos
    These were pushed to CR in
      http://www.w3.org/TR/2004/CR-css3-ui-20040511/#pseudo-ro-rw
    along with the other form-state pseudos,
    so I'm not sure why they're still prefixed.
    Are there issues with these selectors that we need to sort out?

  :-moz-ui-invalid as :user-error
    http://www.w3.org/TR/selectors4/#user-pseudos

  :-moz-placeholder sortof as :placeholder-shown
    http://www.w3.org/TR/selectors4/#placeholder
    due to requests for ::placeholder as a pseudo-elements

  :-moz-drag-over as :drop or :drop()
    https://drafts.csswg.org/selectors-4/#drag-pseudos

(B) Things I'm guessing we want to standardize:

  :-moz-ui-valid
    https://developer.mozilla.org/en-US/docs/Web/CSS/%3A-moz-ui-valid

(C) Things I'm guessing we don't want to standardize:

  :-moz-empty-except-children-with-localname
  :-moz-bound-element
  :-moz-is-html
  :-moz-native-anonymous
  :-moz-system-metric
  :-moz-locale-dir
  :-moz-table-border-nonzero
  :-moz-devtools-highlighted

  :-moz-handler-clicktoplay
  :-moz-handler-playpreview
  :-moz-handler-vulnerable-updatable
  :-moz-handler-vulnerable-no-update
  :-moz-handler-disabled
  :-moz-handler-blocked
  :-moz-handler-crashed

  :-moz-math-increment-script-level

  :-moz-lw-theme
  :-moz-lwtheme-brighttext
  :-moz-lwtheme-darktext

(D) Things I can't tell whether they're things we should standardize:

  :-moz-first-node
  :-moz-last-node

  :-moz-window-inactive

  :-moz-full-screen
  :-moz-full-screen-ancestor

  :-moz-focusring

  :-moz-broken
  :-moz-user-disabled
  :-moz-suppressed
  :-moz-loading
  :-moz-type-unsupported
  :-moz-type-unsupported-platform

(E) Things I'm totally confused about:

  :-moz-meter-optimum
  :-moz-meter-sub-optimum
  :-moz-meter-sub-sub-optimum
  Seem to be explained by
    http://blog.teamtreehouse.com/use-meter-progress-elements
  except a lot of stuff mentioned there is not in the codebase??

--------------------------------------------------------------------

My questions are

  1. Is there anything above that's not on the correct list?
  2. Can you help me sort list (D)?
  3. Anyone have a better name for :blank?
  4. Let me know what's up with :read-write and :read-only?
  5. Please review the :drop spec for correctness/sanity~?
     https://drafts.csswg.org/selectors-4/#drag-pseudos
  6. Ditto :user-error
     https://drafts.csswg.org/selectors-4/#user-pseudos
  7. Any other comments?

Thanks~
~fantasai
_______________________________________________
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform

Reply via email to