Hi, today, I continued to work on the serna package. The achievements are:
(Patch names respective to http://git.nomeata.de/?p=serna.git;a=tree;f=debian/patches;hb=bbeea2bed0403ae5077d995423552ed402a63f35 later revisions might carry updated patches, but then the patch numbers might change) I re-did the patches that are about architecture independence. I splitted them by issue, so that each bit can either be merged into your SVN trunk completely or not. I’ll walk you through: 0002-Template-function-overlap.patch hmm, can probably be dropped now. I’ll check. 0003-Atomic-increment-decrement-defined-for-amd64.patch please merge. Atomic increment/decrement is defined for amd64 0007-Use-void-when-debug-outputting-a-pointer.patch Some casts to (int) are used in output strings. Using (intptr_t) is always correct and yields the same behaviour. 0009-libsp-adjustments-for-64-bits.patch Makes the instances independent of size_t, but makes sure there is one for int and long int. Can be merged. 0020-Cast-via-intptr_t-in-refCntData-new.patch This needs review. I don’t really understand what 18 - const size_type buf_offset((size_type)&((RefCntData*)1)->buf_ - 1); was supposed to do (get a pointer to the 1? but where is the one?) Anyways, 19 + const size_type buf_offset((size_type)(intptr_t)&((RefCntData*)1)->buf_ - 1); seems to work better... 0021-Cast-to-intptr_t-in-Dav-DavManager-lock-calls.patch The code uses the pointer address of the object to generate a unique id as an it. Casting via intptr_t works always. Can be merged. 0022-Cast-to-intptr_t-in-String-number-calls.patch Same thing when casting to provide an argument to String::number: intptr_t is the correct type to use. Can be merged. 0023-Cast-to-intptr_t-in-xslt-impl-Instance.cxx.patch This changes part of the debugging output. Prevoius code did a check ((int)nsiContext().node() > 0x1000000) to see whether the node name is valid. This looks fishy and non-portable. Casting to (intptr_t) works, not sure if it’s still the intended purpose. 0024-Cast-to-intptr_t-in-PackedPtrSet.h.patch Here, the last bit of a pointer is checked. Casting to (intptr_t) is again the correct thing to do. Can be merged. 0025-Remove-__int__-method-from-SimpleWrappedObject.patch Now this is somewhat intrusive: I did not immediately figure out how to implement the __int__ method correctly. But I expect that any use of it is a mistake anyhow, so I just removed it. Where is it used? 0026-Cast-to-long-int-in-pyplugin-stuff.patch I’ll remove this, it’s overwritten by a later patch (28). Please ignore 0027-Implement-PropertyNode-set-get-Ptr-and-String-toPtr.patch As the name says. Some code stores functions pointers in properties, this interface allows this without casts to integers. Can be merged. 0028-Use-set-getPtr-in-pyconsole-code.patch Use the just added functions. Can be merged. I’d obviously like to reduce the number of patches I have to drag along, so please check if you can apply these to SVN. I also made the serna package build and run without its own copy of docbook-xsl. It uses the installed package in /usr/share/xml/docbook/stylesheet/docbook-xsl. I started by adding proper code to 3rd/docbook/docbook-default.t in patch 0029-Allow-using-the-system-wide-docbook-xsl-installation.patch, but the path to the docbook-xsl files was still hardcoded in too many places; see patch 0033-Refer-to-usr-share-xml-docbook-stylesheet-docbook-xs.patch I made serna use xsltproc from the path in patches 0030-Use-system-wide-xsltproc-in-scripts.patch 0031-Use-system-wide-xsltproc-in-publishing-plugin.patch These patches can obviously not be merged. But it would be great if you could make them obsolete: If I run ./configure syspkg in 3rd, serna should always use the system wide xsltproc. Generally, I can not stress enough that reducing the number of patches I need to carry is a great way to ease my work :-) I’m considering to propose the package for inclusion in the current state, and see what the ftp-masters want me to fix. Greetings, Joachim -- Joachim "nomeata" Breitner Debian Developer nome...@debian.org | ICQ# 74513189 | GPG-Keyid: 4743206C JID: nome...@joachim-breitner.de | http://people.debian.org/~nomeata
signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil