Package: lintian
Version: 2.5.3
Severity: wishlist
Tags: patch
I find missing-build-dependency-for-dh_-command a bit hard to read,
especially when the required dependency contains spaces, e.g.:
missing-build-dependency-for-dh_-command dh_python2=python | python-all |
python-dev | python-all-dev
Could we do s/=/ => /? That'd be the same format that is used for
missing-dep-for-interpreter.
I know that changing such things is not necessarily nice for our users,
but the tag is relatively new and there are currently no overrides in
the archive, so maybe it's not too late.
--
Jakub Wilk
diff --git a/checks/debhelper b/checks/debhelper
--- a/checks/debhelper
+++ b/checks/debhelper
@@ -344,7 +344,7 @@
}
while (my ($dep, $command) = each %missingbdeps) {
next if $dep eq 'debhelper'; #handled above
- tag 'missing-build-dependency-for-dh_-command', "$command=$dep"
+ tag 'missing-build-dependency-for-dh_-command', "$command => $dep"
unless ($bdepends_noarch->implies($dep));
}
while (my ($dep, $addon) = each %missingbdeps_addons) {