On Sun, Sep 06, 2015 at 11:14:28AM +0200, Michael Schaller wrote: > Julian, I've went ahead and implemented the changes you've requested and > updated my development branch: > https://github.com/michael-schaller/python-apt/commits/dev
Thanks, we're almost done. I was about to merge this, but noticed a few things: * You don't need to assign "tvers = self.target_versions" before the list comprehension, that just reduces readability. Better split the comprehension over two lines if neede * Version.is_installed has no .. versionadded:: 1.0.0 * The changed __eq__ method might want a .. versionchanged:: 1.0.0 * I don't really understand why you add type comments everywhere. And I really need the changes documented in doc/source/whatsnew/1.0 add some point, otherwise people do not notice them. But I guess that's my work, as I still need to add your other changes I merged there. -- Julian Andres Klode - Debian Developer, Ubuntu Member See http://wiki.debian.org/JulianAndresKlode and http://jak-linux.org/. Be friendly, do not top-post, and follow RFC 1855 "Netiquette". - If you don't I might ignore you.