[
https://issues.apache.org/jira/browse/HADOOP-10646?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Alejandro Abdelnur updated HADOOP-10646:
----------------------------------------
Summary: KeyProvider buildVersionName method should be moved to a utils
class (was: KeyProvider buildVersion method should be moved to a utils class)
> KeyProvider buildVersionName method should be moved to a utils class
> --------------------------------------------------------------------
>
> Key: HADOOP-10646
> URL: https://issues.apache.org/jira/browse/HADOOP-10646
> Project: Hadoop Common
> Issue Type: Bug
> Components: security
> Affects Versions: 3.0.0
> Reporter: Alejandro Abdelnur
> Assignee: Alejandro Abdelnur
> Fix For: 3.0.0
>
>
> The buildVersion() method should not be part of the KeyProvider public API
> because keyversions could be opaque (not built based on the keyname and key
> generation counter).
> KeyProvider implementations may choose to use buildVersion() for reasons such
> as described in HADOOP-10611.
--
This message was sent by Atlassian JIRA
(v6.2#6252)