[
https://issues.apache.org/jira/browse/HADOOP-9966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13771048#comment-13771048
]
Hadoop QA commented on HADOOP-9966:
-----------------------------------
{color:red}-1 overall{color}. Here are the results of testing the latest
attachment
http://issues.apache.org/jira/secure/attachment/12603872/HADOOP-9966.000.patch
against trunk revision .
{color:red}-1 patch{color}. The patch command could not apply the patch.
Console output:
https://builds.apache.org/job/PreCommit-HADOOP-Build/3107//console
This message is automatically generated.
> Refactor XDR code into XDRReader and XDRWriter
> ----------------------------------------------
>
> Key: HADOOP-9966
> URL: https://issues.apache.org/jira/browse/HADOOP-9966
> Project: Hadoop Common
> Issue Type: Improvement
> Components: nfs
> Reporter: Haohui Mai
> Assignee: Haohui Mai
> Attachments: HADOOP-9966.000.patch
>
>
> Several methods in the current XDR class have ambiguous semantics. For
> example, Size() returns the actual size of internal byte array. The actual
> size of current buffer, is also affected by read requests, which pull data
> out of the buffer.
> These ambiguous semantics makes removing redundant copies on the NFS paths
> difficult.
> This JIRA proposes to decompose the responsibilities of XDR into two separate
> class: XDRReader and XDRWriter. The overall designs should closely follow
> Java's *Reader / *Writer classes.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira