[ 
https://issues.apache.org/jira/browse/HADOOP-9848?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13737037#comment-13737037
 ] 

Alejandro Abdelnur commented on HADOOP-9848:
--------------------------------------------

[~ywskycn], on the new {{KerberosSecurityTestcase}} class:

* abstract class is good
* instead using @Before and @After, [~daryn] was suggesting @BeforeClass and 
@AfterClass, this makes the KDC to come up once for all tests in the testcase 
class, before the first one, and shutdown after the last one. I think that is 
better as starting the kdc takes its good second. Note that the methods 
annotated with @BeforeClass and @AfterClass must be static.
* The getTestDir() and and createConf() should be concrete methods in this 
class.
* The createConf() method should be renamed to the more explicit 
createMiniKdcConf() name.
* The instance vars should be private, the should be a 'MiniKdc getKdc()' method

After those changes it looks good to me to go in, then we can start with using 
it in hadoop-auth for the SPNEGO imp.
                
> Create a MiniKDC for use with security testing
> ----------------------------------------------
>
>                 Key: HADOOP-9848
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9848
>             Project: Hadoop Common
>          Issue Type: New Feature
>          Components: security, test
>            Reporter: Wei Yan
>            Assignee: Wei Yan
>         Attachments: HADOOP-9848.patch, HADOOP-9848.patch, HADOOP-9848.patch
>
>
> Create a MiniKDC using Apache Directory Server. MiniKDC builds an embedded 
> KDC (key distribution center), and allows to create principals and keytabs on 
> the fly. MiniKDC can be integrated for Hadoop security unit testing.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to