This is an automated email from the ASF dual-hosted git repository. jlli pushed a change to branch add-option-to-fail-offline-job-on-empty-record in repository https://gitbox.apache.org/repos/asf/incubator-pinot.git.
discard 6b8e0a9 Add an option to fail segment creation job when getting empty files add 318a4c8 Add toString method in PinotMetricName interface (#6663) add 3b70930 Kinesis implementation Part 1: Rename partitionId to partitionGroupId (#6655) add 290a871 Add an option to fail segment creation job when getting empty files add cd5d805 Address PR comment This update added new revisions after undoing existing revisions. That is to say, some revisions that were in the old version of the branch are not in the new version. This situation occurs when a user --force pushes a change and generates a repository containing something like this: * -- * -- B -- O -- O -- O (6b8e0a9) \ N -- N -- N refs/heads/add-option-to-fail-offline-job-on-empty-record (cd5d805) You should already have received notification emails for all of the O revisions, and so the following emails describe only the N revisions from the common base, B. Any revisions marked "omit" are not gone; other references still refer to them. Any revisions marked "discard" are gone forever. No new revisions were added by this update. Summary of changes: .../segmentselector/RealtimeSegmentSelector.java | 2 +- .../apache/pinot/common/utils/LLCSegmentName.java | 24 ++--- .../org/apache/pinot/common/utils/SegmentName.java | 4 +- .../pinot/common/utils/SegmentNameBuilderTest.java | 20 ++-- .../segment/RealtimeSegmentAssignment.java | 23 ++--- .../realtime/PinotLLCRealtimeSegmentManager.java | 106 +++++++++++---------- .../SegmentSizeBasedFlushThresholdUpdater.java | 4 +- .../PinotLLCRealtimeSegmentManagerTest.java | 79 +++++++-------- .../realtime/LLRealtimeSegmentDataManager.java | 46 ++++----- .../manager/realtime/RealtimeTableDataManager.java | 17 ++-- .../generator/SegmentGeneratorConfig.java | 10 +- .../impl/SegmentIndexCreationDriverImpl.java | 2 +- .../realtime/LLRealtimeSegmentDataManagerTest.java | 20 ++-- ...PartitionLLCRealtimeClusterIntegrationTest.java | 22 ++--- .../hadoop/job/mappers/SegmentCreationMapper.java | 2 +- .../plugin/metrics/yammer/YammerMetricName.java | 5 + .../RealtimeToOfflineSegmentsTaskGenerator.java | 11 ++- .../apache/pinot/spi/metrics/PinotMetricName.java | 6 ++ 18 files changed, 210 insertions(+), 193 deletions(-) --------------------------------------------------------------------- To unsubscribe, e-mail: commits-unsubscr...@pinot.apache.org For additional commands, e-mail: commits-h...@pinot.apache.org