This is an automated email from the ASF dual-hosted git repository. squakez pushed a commit to branch main in repository https://gitbox.apache.org/repos/asf/camel-k.git
commit af5b6bf3b03a6018a6dc263e5abf2789b452dbd3 Author: Keerthan <[email protected]> AuthorDate: Thu Sep 24 17:20:08 2026 +0530 Fix #5935: Add note on ArkMQ headless service convention and future consistency --- pkg/util/bindings/arkmq.go | 2 ++ 1 file changed, 2 insertions(+) diff --git a/pkg/util/bindings/arkmq.go b/pkg/util/bindings/arkmq.go index 804bd7e67..75193b90a 100644 --- a/pkg/util/bindings/arkmq.go +++ b/pkg/util/bindings/arkmq.go @@ -227,6 +227,8 @@ func (a ArkMQBindingProvider) getBrokerURL(ctx BindingContext, clusterName, name } } + // NOTE: this is a first implementation that follows the ArkMQ headless service naming convention (<clusterName>-hdls-svc), + // but further development may be needed to make it more consistent. svcName := fmt.Sprintf("%s-hdls-svc", clusterName) svc, err := kubernetes.LookupService(ctx.Ctx, ctx.Client, namespace, svcName) if err != nil {
