compnerd added inline comments.
================ Comment at: clang/lib/CodeGen/CGAtomic.cpp:883 if (UseLibcall) { + CGM.getDiags().Report(E->getLocStart(), diag::warn_atomic_op_misaligned); + ---------------- t.p.northover wrote: > compnerd wrote: > > It is kinda unfortunate that you need to look up 125 lines to get the > > context that the call here is implied by a lack of alignment. Perhaps we > > can rename `UseLibcall` to `UnsuitableAligned` or something? > I'd be OK with that, or I could just move the diagnostic further up so it is > next to the definition (or maybe just after to avoid the atomic_init case)? That addresses my concern too, the choice is yours :-) Repository: rC Clang https://reviews.llvm.org/D45319 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits