rjmccall added inline comments.
================ Comment at: lib/CodeGen/CGExpr.cpp:3665 -LValue CodeGenFunction::EmitLValueForField(LValue base, - const FieldDecl *field) { - LValueBaseInfo BaseInfo = base.getBaseInfo(); - AlignmentSource fieldAlignSource = - getFieldAlignmentSource(BaseInfo.getAlignmentSource()); - LValueBaseInfo FieldBaseInfo(fieldAlignSource, BaseInfo.getMayAlias()); +LValue CodeGenFunction::EmitLValueForField(LValue BaseExpr, + const FieldDecl *Field) { ---------------- The new name here doesn't make sense; the base is not an expression, it's an l-value. That and the change in capitalization make it hard to track down the changes you've made to each branch here. I believe all you're doing for the other path is sinking some code past the isBitField() block. Repository: rL LLVM https://reviews.llvm.org/D38947 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits