hfinkel added inline comments.
================ Comment at: lib/Driver/ToolChains/Cuda.cpp:442 + SmallString<256> Name = llvm::sys::path::relative_path(II.getFilename()); + SmallString<256> FullPath = llvm::sys::path::root_path(II.getFilename()); llvm::sys::path::replace_extension(Name, "cubin"); ---------------- Naming this FullPath seems inaccurate. It's not the full path, it's the root path (which is just the root_name + root_directory, but not any directory after that). In any case, I don't see why all of this is necessary. Can't you just have: SmallString<256> Name = II.getFilename(); llvm::sys::path::replace_extension(Name, "cubin"); const char *CubinF = C.addTempFile(C.getArgs().MakeArgString(Name)); https://reviews.llvm.org/D37912 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits