yamaguchi added inline comments.
================ Comment at: lib/Sema/SemaInit.cpp:892 + SpellingLoc = SemaRef.getSourceManager().getSpellingLoc(SpellingLoc); + if (!(SpellingLoc.isValid() && + SemaRef.getSourceManager().isInSystemHeader(SpellingLoc))) { ---------------- yamaguchi wrote: > v.g.vassilev wrote: > > yamaguchi wrote: > > > v.g.vassilev wrote: > > > > I'd avoid double negations. Could you use `isInvalid` instead of > > > > `!isValid`. That would make the condition more readable. > > > It's not (!SpellingLoc.isValid()) but is !((SpellingLoc.isValid() && > > > SemaRef.getSourceManager().isInSystemHeader(SpellingLoc)) > > > > > I'd rewrite this using early returns: > > ``` > > if (SpellingLoc.isInvalid() || > > SemaRef.getSourceManager().isInSystemHeader(SpellingLoc)) > > return; > > ... > > ``` > Do you think I should change this to (SpellingLoc.isInvalid() || > !(SemaRef.getSourceManager().isInSystemHeader(SpellingLoc)) ?? Oh, I see. Sorry I didn't see your reply because I was typing mine. https://reviews.llvm.org/D32646 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits