hokein accepted this revision. hokein added inline comments. This revision is now accepted and ready to land.
================ Comment at: change-namespace/tool/ClangChangeNamespace.cpp:68 +cl::opt<bool> + DumpYAML("dump_yaml", + cl::desc("Dump new file content in YAML, if specified."), ---------------- hokein wrote: > `dump_result` maybe a clearer name, which also is consistent with > clang-move's. Nit: Also change the variable name to `DumpResult`. ================ Comment at: change-namespace/tool/ClangChangeNamespace.cpp:137 + + for (const auto &File : ChangedFiles) { const auto *Entry = FileMgr.getFile(File); ---------------- ioeric wrote: > hokein wrote: > > Is this duplicated as we already have "dump_results" option now? > I'd like this to be default since this produces readable results. OK, it is up to you. https://reviews.llvm.org/D29893 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits