zaks.anna accepted this revision. zaks.anna added a comment. This revision is now accepted and ready to land.
Thank you! ================ Comment at: lib/StaticAnalyzer/Core/RangeConstraintManager.cpp:459 // Notice that the lower bound is greater than the upper bound. - RangeSet New = GetRange(St, Sym).Intersect(getBasicVals(), F, Upper, Lower); + RangeSet New = getRange(St, Sym).Intersect(getBasicVals(), F, Upper, Lower); return New.isEmpty() ? nullptr : St->set<ConstraintRange>(Sym, New); ---------------- ddcc wrote: > zaks.anna wrote: > > ddcc wrote: > > > zaks.anna wrote: > > > > We should use lower case function names. > > > Are you saying more functions should be changed to lowercase (e.g. > > > intersect)? Or that `getRange` should be `getrange`? > > Should be "camel case, and start with a lower case letter", see: > > > > http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly > Right, isn't changing `GetRange` to `getRange` correct then? I'm a little > confused, is there something else that needs to be fixed? Sorry, my bad. This does look good! https://reviews.llvm.org/D26691 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits