t-rasmud added inline comments.

================
Comment at: clang/lib/Analysis/UnsafeBufferUsage.cpp:2719
+  Strategy NaiveStrategy = getNaiveStrategy(
+      llvm::make_range(VisitedVars.begin(), VisitedVars.end()));
   VariableGroupsManagerImpl VarGrpMgr(Groups, VarGrpMap, GrpsUnionForParms);
----------------
ziqingluo-90 wrote:
> `VisitedVars` are the set of variables on the computed graph.  The previous 
> `UnsafeVars` is a superset of it, including safe variables that have 
> `FixableGadget`s discovered.  We do not want to assign strategies other than 
> `Won't fix` to those safe variables.
Would it make more sense (make the code more readable) if we renamed 
`UnsafeVars` to say, `FixableVars`?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D157441/new/

https://reviews.llvm.org/D157441

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to