bogner added inline comments.
================ Comment at: llvm/include/llvm/Option/OptParser.td:153 class Flags<list<OptionFlag> flags> { list<OptionFlag> Flags = flags; } +class Vis<list<OptionVisibility> vis> { list<OptionVisibility> Vis = vis; } class Group<OptionGroup group> { OptionGroup Group = group; } ---------------- phosek wrote: > Would it be possible to spell this out in full, that is `Visibility` rather > than `Vis`? It's more consistent with all other attributes and improves > readability in my opinion. Sure, I can change it. I went with brevity thinking that it would help readability, especially in clang's Options.td, but I'm fairly okay with either way. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D157149/new/ https://reviews.llvm.org/D157149 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits