alexfh accepted this revision. alexfh added a comment. This revision is now accepted and ready to land.
LG ================ Comment at: clang-tidy/readability/ContainerSizeEmptyCheck.cpp:35 @@ +34,3 @@ + hasName("size"), returns(isInteger()), + unless(returns(booleanType()))) + .bind("size")), ---------------- You could probably combine the two `returns` matchers. Something like this: `returns(qualType(isInteger(), unless(booleanType())))`. https://reviews.llvm.org/D24349 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits