tra accepted this revision. tra added inline comments. This revision is now accepted and ready to land.
================ Comment at: llvm/test/CodeGen/NVPTX/ldu-ldg.ll:5-6 declare i8 @llvm.nvvm.ldu.global.i.i8.p1(ptr addrspace(1) %ptr, i32 %align) declare i32 @llvm.nvvm.ldu.global.i.i32.p1(ptr addrspace(1) %ptr, i32 %align) + ---------------- Do we want to add missing `ldu` variants, too? ================ Comment at: llvm/test/CodeGen/NVPTX/ldu-ldg.ll:39 ; CHECK: func3 -define i32 @func3(ptr addrspace(1) %ptr) { +define i16 @func3(ptr addrspace(1) %ptr) { +; ld.global.nc.u16 ---------------- Nit: I'd give test functions more descriptive names. E.g. `test_ldg_u16`. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D144961/new/ https://reviews.llvm.org/D144961 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits