sdesmalen added inline comments.
================ Comment at: clang/lib/Headers/CMakeLists.txt:332 + # Generate arm_sme.h + clang_generate_header(-gen-arm-sme-header arm_sme.td arm_sme.h) # Generate arm_bf16.h ---------------- bryanpkc wrote: > bryanpkc wrote: > > sdesmalen wrote: > > > The ACLE specification is still in a draft (ALP) state, which means there > > > may still be subject to significant changes. To avoid users from using > > > this implementation with the expectation that their code is compliant > > > going forward, it would be good to rename the header file to something > > > that makes it very clear this feature is not yet ready to use. I'm > > > thinking of something like `arm_sme_draft_spec_subject_to_change.h`. When > > > the specification goes out of draft, we can rename it to `arm_sme.h`. > > > Could you rename the file for now? > > Would something shorter like `arm_sme_draft.h` or `arm_sme_experimental.h` > > suffice? > Renamed to `arm_sme_experimental.h`. While `arm_sme_experimental.h` is indeed shorter, it should be unequivocally clear to the user that they shouldn't rely on the function prototypes defined in this header file yet because the specification itself is not finalised. I think that adding the `draft_spec_subject_to_change` to the name makes that more clear than `experimental`, as the latter might suggest that the support is not yet entirely stable or complete. There probably isn't that much to gain from making the user experience better by using a shorter name, if the whole point is to prevent people from using it for any production code. So from that perspective, I still have a slight preference for `arm_sme_draft_spec_subject_to_change.h`. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127910/new/ https://reviews.llvm.org/D127910 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits